×
追加記事
  • RFC 792 — Internet Control Message Protocol

    IPv4におけるICMPの基本仕様です。
    Echo Request(Type 8)とEcho Reply(Type 0)の仕様を確認できます。

    https://www.rfc-editor.org/rfc/rfc792


    RFC 4443 — Internet Control Message Protocol (ICMPv6) for IPv6

    IPv6におけるICMPv6の基本仕様です。
    Echo Request(Type 128)とEcho Reply(Type 129)の仕様を確認できます。

    https://www.rfc-editor.org/rfc/rfc4443


    RFC 4890 — Recommendations for Filtering ICMPv6 Messages in Firewalls

    FirewallでICMPv6をどのようにフィルタリングするべきかを説明したRFCです。

    ICMPv6を一律に遮断すると、IPv6通信に必要なPacket Too BigやNeighbor Discoveryなどへ影響する可能性があります。

    https://www.rfc-editor.org/rfc/rfc4890


    RFC 2827 / BCP 38 — Network Ingress Filtering

    送信元IPアドレスを偽装するIP Spoofingへの代表的な対策であるIngress Filteringを説明しています。

    https://www.rfc-editor.org/rfc/rfc2827


    RFC 2644 — Changing the Default for Directed Broadcasts in Routers

    Smurf攻撃などで利用されるIP Directed Broadcastへの対策を定義しています。

    https://www.rfc-editor.org/rfc/rfc2644


    MITRE ATT&CK T1498 — Network Denial of Service

    ネットワークを大量トラフィックで妨害するNetwork DoS攻撃のMITRE ATT&CK分類です。

    https://attack.mitre.org/techniques/T1498/


    MITRE ATT&CK T1498.001 — Direct Network Flood

    ICMPやUDPなどを利用して対象へ直接大量のネットワークトラフィックを送信する攻撃を扱います。

    PingフラッドやICMPフラッドを理解する際の重要な資料です。

    https://attack.mitre.org/techniques/T1498/001/


    MITRE ATT&CK T1498.002 — Reflection Amplification

    第三者サーバーやネットワーク機器を利用してトラフィックを反射・増幅するDDoS攻撃を扱います。

    Smurf攻撃を理解する際にも参考になります。

    https://attack.mitre.org/techniques/T1498/002/


    Linux Kernel Documentation — IP Sysctl

    Linux KernelのIPv4、ICMP関連sysctl設定を確認できる公式ドキュメントです。

    icmp_echo_ignore_all、icmp_echo_ignore_broadcasts、icmp_ratelimit、icmp_msgs_per_secなどの仕様を確認できます。

    https://docs.kernel.org/networking/ip-sysctl.html


    Netfilter — nftables

    Linuxのnftablesに関する公式プロジェクトサイトです。

    https://www.netfilter.org/projects/nftables/


    nftables Wiki — Rate limiting matchings

    nftablesによるレート制限を確認する際の参考資料です。

    https://wiki.nftables.org/wiki-nftables/index.php/Rate_limiting_matchings。